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Assess Reading Order 
Another important check is reading order. Reading order is the order in which 
an assistive technology like a Screen Reader  (Job Access With Speech JAWS) 
will read aloud the document to the user. When you convert a document 
from Word or PowerPoint over to Adobe PDF format, you are carrying over 
the tags (labels) that identify each component of  that document into PDF. 
The reading order depends on these tags (labels) that are carried over into the 
Adobe PDF document. Tags indicate to the user what items make up the document (headings, 
links, tables, images, text) and the order in which they will be read to the user of  assistive 
technology. A PDF document may visually seem organized and easy to follow for a sighted user, 
but if  the native documents were not created with accessibility in mind before converting these 
over into PDF, JAWS and any other screen reading software will unveil a jumble of  
incomprehensible words to a blind/low vision user trying to access the document. Fortunately, 
there are a few things you can do in Adobe Acrobat to check for reading order of  your PDF. 
 
In Adobe Acrobat, reading order can be checked by assessing the Order Panel and the Tags 
Panel. Both panels should display the same order so that the content can be read in the same 
order whether it stays as a PDF or is exported into a Text (Accessible) version. The exported 
Text (Accessible) version of  the PDF displays content in the order specified by the Tags Panel 
of  the PDF. The Read Out Loud Feature in Adobe Acrobat and screen reading software such as 
Job Access With Speech (JAWS) also reads content in the order indicated by the Tags Panel. Edit 
the tags and order panels appropriately so that they match by following the steps indicated in the 
sections below. Since most of  your edits to the PDF will be done using the Order Panel and the 
TouchUp Reading Order Tool, once you are done doing edits in the Order Panel, go to the Tags 
panel and make sure the tags read in the correct order as shown in the Order Panel. Just because 
the reading order is correct in the Order Panel does not mean it is correct on the tags panel. 
Remember, assistive technology reads PDF content based on the reading order indicated in the 
Tags Panel so be sure it is correct! 

Using the Tags Panel 
As mentioned earlier the tags panel displays all the structural elements contained in your 
document such as paragraphs, headings, links, lists, images etc. The order in which these items 
are displayed is the order in which they will be read out loud to a user of  assistive technology, 
thus, it is important to ensure that the tag order is correct and that tags are not missing. Begin by 
opening the tags panel: 

If  the tags panel is not showing on the navigation bar, go to the View menu > 
Navigation Panels > select Tags. This will open the Content, Order and Tags panels 
in a small window. You can dock each panel on the left navigation bar by clicking on 
the tab name for each panel and dragging and dropping into the navigation panel. 
Click on the tags panel to view the tags panel (see Tools of  the Trade section to 
learn how to dock these panels).  
In the tags panel you will see an icon labeled tags which has a (+) expand button 
next to it. Click the expand (+) button to expand the list of  tags. The expanded tags 
list may still contain collapsed items so you will need to make sure to click on all of  
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the (+) expand buttons to see all tags contained in document. Take note of  the tag 
order. 
To highlight content on your PDF as you click through tag items, click on the 
Options drop down menu > select Highlight Content.  
 
 
 
 
 
 
 
 
 
 
 
 
 
Move tags around by clicking on a tag so that it is highlighted and dragging and 
dropping it to the correct location. 

In this example (at right), the Tags Panel shows 
reading order beginning with an empty 
paragraph and a figure. The Read Out Loud 
Feature in Acrobat and screen reading software 
like JAWS will read the PDF by announcing the 
figure information since it goes by what is 
delineated in the tags panel.
 
 
 
 
 

 

Using the Order Panel
When you open your PDF document in Adobe Acrobat the first thing you will notice are a 
series of  menus at the top and left side of  the window. The Order Panel is located on the Left 
side of  the window (Navigation Panel) and allows you to view, re-order and re-tag structured 
PDF information. To view the Order Panel do the following: 
 

Click the Order button located on the navigation panel on the left side of  the window. 
If  the Order button is not docked on the left side of  the window: 

Go to the View Menu, select Navigation Panels, and select Order. The Order 
button will now be available for you to select from the Navigation Panel on the left. 
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The Order Panel will display. In the Order Panel you will see the outline of  all the 
pages and components that make up your document. If  this outline is not already 
expanded, you can select the maximize button (+) next to the name of  the document in 
the Order Panel to expand it. 

The Order panel

When you select the Order Panel, a series of  numbered gray boxes will highlight the different 
components that make up your PDF document indicating numerically the reading order of  each 
component and section on each page. The numbers match up with the numbered items you see 
in the Order Panel. Notice that when you select an item from the order panel, the gray boxes on 
the document will become highlighted in light blue. The gray numbered boxes start at number 1 
on each page of  the PDF document. Take note of  any items in the document that are labeled 
numerically in the wrong order. This will affect in the order the items are read to a user using a 
screen reader and in the order the information appears in a text version of  the PDF document.  
 
Notice that the reading order for the PDF document shown above begins with “New Workshop 
for Faculty” in the Order Panel. This does not match the reading order in the Tags Panel which 
begins with information about figures in the PDF as seen in our example in the Using the Tags 
Panel section of  this document. You will need to correct the reading order in the Order Panel 
to match that of  the Tags Panel, or if  you want the PDF to be read in the order the Order Panel 
displays, you will need to go back into the tags panel and re-arrange the tags accordingly.  

 
To correct the reading order of  a PDF document do the following: 
 

From the Order Panel, navigate to the page of  the document that has the incorrect 
reading order. 
Expand the outline of  items for that page by clicking the expand (+) button. 
You will see a series of  small tan box icons next to each component on that page. 
Noting the number of  the items on the page, place your cursor on the tan box for the 
component you want to re-order, and drag and drop the box above or below items in 
the outline. The selected item will be re-numbered according to the location where it 
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was dragged and dropped. Verify between the document view and the order panel that 
the items are numbered correctly.
After editing the reading order go back to the Tags Panel and make sure the tags panel 
matches the order panel. If  it does not, then begin re-ordering tags as appropriate. 

Exporting a Text (Accessible) version of PDF
After you have finished editing the reading order so that it matches both in the Order Panel and 
in the Tags panel you should save as or export the document as a Text (Accessible) file. Doing 
so will generate a text version of  the PDF and allow you to see how the document is organized 
and would be read by a screen reader. Remember, the Text (Accessible) file is generated based 
on the reading order established in the Tags Panel! 
 
To Save the file as a Text (Accessible) file: 

Go to the File Menu and select Save As. 
The Save As window appears. From the Save As Type drop down menu, select Text 
(Accessible) (.txt) option. 
Click the Save button to save the file. 

To Export the file as a Text (Accessible) file; 
Go to the File Menu and select Export > Text > Text (Accessible) 
The Save As window appears. Click the Save button to save the file. 

Once you have saved or exported the PDF 
file as a Text (Accessible) version, open the 
text file and review the text to make sure 
that it is displayed in the correct order. You 
can use the text file along with the PDF 
document to compare reading order in the 
Tags panel and re-order items as necessary. 
Make sure to go back to the Order Panel 
and make sure you make the same reading 
order changes there too. In our example of  
the Text (Accessible) version of  the PDF 
(see screenshot at right), notice that the text 
starts with “Sacramento State University” 
which is Alt Text for figure information so 
we see that the text (accessible) content is based on the reading order in the Tags Panel. 

Once you make all necessary checks and corrections to the PDF document to make it accessible, 
save the file with all the changes, and export or save the PDF as a Text (Accessible) file to 
provide students with an accessible alternate format of  the document. Refer to the Alternate 
Formats section of  this document for more information on alternate formats.  
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Using Assistive Technology to Check Reading Order
Now that you have visually assessed the reading order of  the document, the next step is to use 
assistive technology software such as JAWS and the built in screen reading feature in Adobe 
Acrobat, Read Out Loud, to aurally assess reading order. 

Assessing Reading Order with JAWS 
If  JAWS (Job Access With Speech) is installed on your computer, double click on the JAWS 
shortcut icon on your desktop or go to your start menu to locate the program. When JAWS 
opens, it will say “JAWS for Windows is Ready” and announce the title of  the PDF document. 
To begin reading the PDF document select the following keystrokes and listen for the order in 
which the document is read. These are some of  the most common keyboard shortcuts used to 
read the entire document and list items such as links, headings, frames and form fields. To learn 
about more Keyboard Shortcuts for JAWS visit WebAIM’s Keyboard Shortcut for JAWS 
webpage (http://www.webaim.org/resources/shortcuts/jaws.php), and Freedom Scientifics’ 
JAWS Keystrokes webpage (http://www.freedomscientific.com/training/training-JAWS-
keystrokes.htm) 
 

Insert + down arrow = Say All, reads until the end of  the page from where the 
cursor is located 
CTRL = Interrupt Speech 
Insert + Up Arrow = Say Line, Reads the line at the active cursor 
Insert + Left Arrow = Say prior word 
Insert + Right Arrow = Say next word 
Insert + F6 = List of  Headings 
Insert + F7 = List of  Links 
Insert + F9 = List of  Frames 
Insert + F5 = List of  Form fields 
 

Using Adobe Acrobat Read Out Loud Feature 
You can also assess the reading order of  your PDF document by using the built in screen reader 
for Adobe PDF, Read Out Loud (available in Acrobat Reader as well). To access Read Out 
Loud: 

Go to the View menu and select Read Out Loud 
Select Activate Read Out Loud.  
Go back to the View Menu and select Read Out Loud 
You will see three options:  Deactivate Read Out Loud, Read this Page Only or 
Read to End of  Document. Select the appropriate option to read the document. 
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Setting Page Properties for Reading Order 
Go to the View menu > Navigation Panels > select Pages (see screenshot below). 

  
 
 
 
 
 
 
 
 
 
 
 

The Pages Panel will display to the left of  the screen.  
Click the first page displayed in the Pages Panel Pane so that it is highlighted (below).  
 

 
 

Click Options drop down menu 
button and select Page Properties… 
(screenshot at right) 
The Page Properties dialog box 
displays. Under the “Tab Order” tab, 
select the Use Document Structure 
option and click the OK button. 

 
After going through these steps to assess 
reading order of  your document, you will have 
an idea of  how the document is read to a 
screen reader user. Performing the Full Check 
for Accessibility will pinpoint exactly where 
corrections need to be made in the document 
to make it accessible. 




